SSL Medium Strength Cipher Suites Supported (SWEET32) 支持SSL中等强度密码套件(SWEET32)中危漏洞

 2022-01-07 

SSL Medium Strength Cipher Suites Supported (SWEET32) 支持SSL中等强度密码套件(SWEET32)中危漏洞

漏洞描述

远程主机支持使用提供中等强度加密的SSL密码

Nessus将中等强度视为使用至少64位且小于112位的密钥长度的任何加密,否则使用3DES加密套件。

整改建议

nginx修复方法修改/etc/nginx/conf.d/ssl.conf文件
找到ssl_ciphers行:
ssl_ciphers HIGH:!aNULL:!MD5:!DES:!3DES;
然后重载服务器配置:service nginx restart

如果是apache 的话

修改 /usr/local/apache2.4.39/conf/httpd.conf

SSLProtocol all -SSLv2 -SSLv3
SSLHonorCipherOrder on
SSLCipherSuite ALL:!ADH:!EXPORT:!SSLv2:+HIGH:+MEDIUM:-LOW:!RC4:!NULL

LoadModule ssl_module modules/mod_ssl.so

我这边是haproxy开启的https后面转向apache的

根据漏洞号码,查一下那个有风险,去掉就行了,我这边是去掉的3des,然后重置了haproxy服务

vim /etc/haproxy/haproxy.cfg

global
ssl-default-bind-options no-sslv3
ssl-default-bind-ciphers ECDH+AESGCM:DH+AESGCM:ECDH+AES256:DH+AES256:ECDH+AES128:DH+AES:ECDH+3DES:DH+3DES:RSA+AESGCM:RSA+AES:RSA+3DES:!aNULL:!MD5:!DSS

systemctl reload haproxy.service