关于php:安装phpMyAdmin的问题

 2021-04-26 

Problems installing phpMyAdmin

我正在尝试在Centos 7 / PHP 5.6安装上安装phpMyAdmin。不幸的是,由于应用程序迁移的延迟,实际上还不可能升级到PHP 7。*。

当我尝试使用yum安装phpmyadmin时,我得到:

1
2
3
4
5
Error: php56u-common conflicts with php-common-5.4.16-43.el7_4.x86_64
Error: php71u-common conflicts with php56u-common-5.6.33-1.ius.centos7.x86_64
Error: php71u-common conflicts with php-common-5.4.16-43.el7_4.x86_64
You could try using --skip-broken to work around the problem
You could try running: rpm -Va --nofiles --nodigest

使用--skip-broken等无法解决问题。


我通过删除然后重新安装php解决了此问题:

1
2
3
yum remove php php-mysql php-fpm
yum install php php-mysql php-fpm
yum install phpmyadmin